Email Delivery Delay

Incident Report for Smeetz

Resolved

We experienced a temporary block in email delivery due to an IP block affecting our sending infrastructure with our third-party provider, Mailgun.

During this period, some Windows-based domains were delayed. The issue has now been resolved following the configuration update.

We have since no longer observing delivery errors, and email processing has returned to normal. We will continue to monitor closely to ensure ongoing stability and add the necessary improvements.

Thank you.
Posted Feb 25, 2026 - 08:16 CET

Identified

We are currently experiencing a disturbance affecting email delivery, primarily impacting recipients using Windows-based email domains (e.g., Outlook, Hotmail, Live).

As a result, some emails may be delayed. Please note that messages are not lost and will be delivered once the issue is fully resolved.

Our team is actively investigating the situation and working to restore normal delivery times as quickly as possible.

We will provide further updates as soon as more information becomes available.
Posted Feb 24, 2026 - 14:01 CET